YPOPs!/Windows 0.9.7.3 Released

This is a test forum. Use this forum to experiment with the features provided by the discussion forum.


YPOPs!/Windows 0.9.7.3 Released

Postby anujseth on March 10th, 2009, 11:38 am

YPOPs!/Windows 0.9.7.3 has been released.

Download it!

Changelog:
1. Removed ALL third-party libraries (curl, openssl, ...). IMAP<>POP3 does not rely on any of them. When we get to fixing SOAP and SMTP, I'll reintroduce the correct libraries
2. The code has been run thru a Memory checker (Boundschecker) and a few memory corruptions have been fixed.
3. There is no need to install the VC++ 2008 redistributable files.
4. Fix for TOP

As before, I need feedback!

Anuj Seth - YPOPs! Dev & Web Admin
Check out my latest project -- Twitdom - Twitter Applications Database
User avatar
anujseth
Site Admin
Site Admin
 
Posts: 452
Joined: June 24th, 2003, 9:57 am

Re: YPOPs!/Windows 0.9.7.3 Released

Postby Vivek Agarwal on March 10th, 2009, 12:51 pm

Very cool, Anuj! I just downloaded/installed 0.9.7.3 and that seems to have fixed my issues in downloading Yahoo mail. Great work!

Many thanks, Vivek.
Vivek Agarwal
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: March 10th, 2009, 12:47 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby RTS on March 10th, 2009, 1:04 pm

I don't understand the purpose of YPOPs if simply changing my preferred content to YAHOOAsia is all that is needed to enable POP usage.

For 2 years I've used YPOPs and appreciated it very much. Now that we all know about Asia content thing-could someone please tell me:

(1) What is the benefit of having YPOPs installed on my system?
(2) Will I be able to send email?
(3) What's up with all this IMAP talk? I prefer IMAP (having used it with gmail and on iphone) but I don't understand how YPOPs is meaning to implement it.

Best,

BTW I suspect the answers to all of my questions are related and will make YPOPs more attractive- if not then "?"
RTS
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: March 10th, 2009, 12:57 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby Catk on March 10th, 2009, 1:33 pm

Don't work Ypops 0.9.7.3 for me. Do not download nothing from my email account on the server yahoo.com.
I have Windows XP SP 3 and I use Windows Live Mail v. 12.0.1606.
Attachments
YPOPs_0973.zip
(1.45 KiB) Downloaded 2984 times
Catk
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 11
Joined: July 18th, 2006, 2:26 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby mhg on March 10th, 2009, 1:46 pm

I moved up yesterday from 0.9.5.? to 0.9.7.1 since the old version had taken to downloading no mail at all.

I have been struggling for hours with 0.9.7.1 which crashes after downloading e-mail (it works through all the mail) and then appears to die before cleaning up the server (deleting mail etc).

I used to get a popup box with status, but this does not appear to exist any more, so I am not entirely sure what is happening.

Anyway, I saw 0.9.7.3 tonight (yes... much smaller) and installed that. Same problem.

Both versions also appear to be finding 'old' mail that is no longer on the server.

Like others, I ponder the direction. If I can use IMAP just by changing the zone to Asia, then why do I need YPOPS?

YPOPS was a bridge from HTTP / POP3 or IMAP so that web mail could be downloaded to regular mail clients. If IMAP is available on the US based accuonts... then why not go direct?
I know from experience that new UK accounts have IMAP and no Plus! costs. So again, why us YPOPS and UK accounts?

So the last thing that I need to work out is how to do the Asia thing.

I have been using YPOPs since it was YahooPOPs. Thanks for keeping the mail going all this time. It really is appreciated.
mhg
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 1
Joined: March 10th, 2009, 1:38 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby TClarkey on March 10th, 2009, 1:49 pm

My CPU still spikes to 100% with 0.9.7.3.

When outlook (2007) tries to download Ypops logs in and says it successful, but then hangs. When Outlook tries to download again (after 1 minute), the CPU goes from 40% to 70%. After minute 2, it then drags the system to a halt.

It's almost as if it's trying to do something with IMAP but is timing out.

Windows XP Professional sp2

[03/10/09 14:09:40] YPOPs! Version 0.9.7.3
[03/10/09 14:09:40] Configuration:
[03/10/09 14:09:40] Log Mode = Advanced (1)
[03/10/09 14:09:40] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 14:09:40] Max Emails = 40, Leave as unread = 0
[03/10/09 14:09:40] Empty Trash = 0, Empty Bulk = 0
[03/10/09 14:09:40] Download Inbox = 1, Download BulkMail = 1
[03/10/09 14:09:40] Email Category = All
[03/10/09 14:09:40] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 14:09:40] Autostart = 1
[03/10/09 14:09:40] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 14:09:40] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 14:09:40] Apply Limit to Message List = 1, Cookie Timeout = 12000
[03/10/09 14:09:40] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 14:09:40] =========================================================================
[03/10/09 14:09:40] Sending POP3 response to socket 272
[03/10/09 14:09:40] Unknown AUTHORIZATION state command: AUTH
[03/10/09 14:09:40] Sending POP3 response to socket 272
[03/10/09 14:09:40] <tclarkey4> Sending POP3 response to socket 272
[03/10/09 14:09:40] Starting POP3 session for "tclarkey4".
[03/10/09 14:09:40] <tclarkey4> Password received from client.
[03/10/09 14:09:40] <tclarkey4> INBOX added to list of folders to analyze
[03/10/09 14:09:40] <tclarkey4> Bulk Mail added to list of folders to analyze
[03/10/09 14:09:40] <tclarkey4> Login to Yahoo! Mail succeeded
[03/10/09 14:09:40] IMAP Response Dump: 2 OK LOGIN completed
TClarkey
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 7
Joined: December 10th, 2003, 3:25 pm
Location: Chicago

Re: YPOPs!/Windows 0.9.7.3 Released

Postby john191 on March 10th, 2009, 5:05 pm

Even with verion 9.7.3 when i download yahoo mail....ai have problem
1 - the message was downloaded but it was not delete from the yahoo acount...so if ai check message again..i receive the same message. After download they are not delete from yahoo....and then yahoopop crash - "free pop3/smtp access to yahoo! mail has encounter a problem and needs to close - error signature - appname ypops.exe appVer:0.9.7.3 Mod name ypops.exe offset: 000b7a44
2 -some account cand be acces other not...with the same settings in yahoo pop and outlook expres 6. Its verry strange.
Sorry for my english.
i use xp with sp3
john191
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: March 10th, 2009, 10:58 am

Re: YPOPs!/Windows 0.9.7.3 Released

Postby dethknite on March 10th, 2009, 6:45 pm

I just get Outlook hanging forever... like it is trying to connect... Hopefully log can shed more light to where in the code. Tried changing server to Yahoo Asia... still no luck.

Thanks for all the effort you are putting into this recently.

[03/10/09 20:36:46] YPOPs! Version 0.9.7.3
[03/10/09 20:36:46] Configuration:
[03/10/09 20:36:46] Log Mode = Advanced (1)
[03/10/09 20:36:46] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 20:36:46] Max Emails = 40, Leave as unread = 0
[03/10/09 20:36:46] Empty Trash = 1, Empty Bulk = 1
[03/10/09 20:36:46] Download Inbox = 1, Download BulkMail = 1
[03/10/09 20:36:46] Email Category = All
[03/10/09 20:36:46] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 20:36:46] Autostart = 1
[03/10/09 20:36:46] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 20:36:46] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 20:36:46] Apply Limit to Message List = 1, Cookie Timeout = 12000
[03/10/09 20:36:46] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 20:36:46] =========================================================================
[03/10/09 20:36:46] Sending POP3 response to socket 880
[03/10/09 20:36:46] Unknown AUTHORIZATION state command: AUTH
[03/10/09 20:36:46] Sending POP3 response to socket 880
[03/10/09 20:36:46] <dethknite> Sending POP3 response to socket 880
[03/10/09 20:36:46] Starting POP3 session for "dethknite".
[03/10/09 20:36:46] <dethknite> Password received from client.
[03/10/09 20:36:46] <dethknite> INBOX added to list of folders to analyze
[03/10/09 20:36:46] <dethknite> Bulk Mail added to list of folders to analyze
[03/10/09 20:36:46] <dethknite> Login to Yahoo! Mail succeeded
[03/10/09 20:36:46] IMAP Response Dump: 2 OK LOGIN completed
[03/10/09 20:41:44] YPOPs! is exiting.
[03/10/09 20:41:45] YPOPs! v0.9.7.3 started successfully
[03/10/09 20:41:45] =========================================================================
[03/10/09 20:41:45] YPOPs! Version 0.9.7.3
[03/10/09 20:41:45] Configuration:
[03/10/09 20:41:45] Log Mode = Advanced (1)
[03/10/09 20:41:45] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 20:41:45] Max Emails = 40, Leave as unread = 0
[03/10/09 20:41:45] Empty Trash = 1, Empty Bulk = 1
[03/10/09 20:41:45] Download Inbox = 1, Download BulkMail = 1
[03/10/09 20:41:45] Email Category = All
[03/10/09 20:41:45] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 20:41:45] Autostart = 1
[03/10/09 20:41:45] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 20:41:45] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 20:41:45] Apply Limit to Message List = 1, Cookie Timeout = 12000
[03/10/09 20:41:45] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 20:41:45] =========================================================================
dethknite
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: February 26th, 2009, 10:02 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby zomby_d_wulf on March 10th, 2009, 7:00 pm

XP sp3 outlook 2007
outlook is finally connecting, it downloads 1 or 2 emails then ypops crashes.


[03/10/09 18:43:53] YPOPs! v0.9.7.3 started successfully
[03/10/09 18:43:53] =========================================================================
[03/10/09 18:43:53] YPOPs! Version 0.9.7.3
[03/10/09 18:43:53] Configuration:
[03/10/09 18:43:53] Log Mode = Advanced (1)
[03/10/09 18:43:53] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 18:43:53] Max Emails = 400, Leave as unread = 0
[03/10/09 18:43:53] Empty Trash = 1, Empty Bulk = 1
[03/10/09 18:43:53] Download Inbox = 1, Download BulkMail = 1
[03/10/09 18:43:53] Email Category = All
[03/10/09 18:43:53] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 18:43:53] Autostart = 0
[03/10/09 18:43:53] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 18:43:53] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 18:43:53] Apply Limit to Message List = 1, Cookie Timeout = 3000
[03/10/09 18:43:53] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 18:43:53] =========================================================================
[03/10/09 18:44:17] YPOPs! is exiting.
[03/10/09 18:44:20] YPOPs! v0.9.7.3 started successfully
[03/10/09 18:44:20] =========================================================================
[03/10/09 18:44:20] YPOPs! Version 0.9.7.3
[03/10/09 18:44:20] Configuration:
[03/10/09 18:44:20] Log Mode = Advanced (1)
[03/10/09 18:44:20] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 18:44:20] Max Emails = 400, Leave as unread = 0
[03/10/09 18:44:20] Empty Trash = 1, Empty Bulk = 1
[03/10/09 18:44:20] Download Inbox = 1, Download BulkMail = 1
[03/10/09 18:44:20] Email Category = All
[03/10/09 18:44:20] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 18:44:20] Autostart = 0
[03/10/09 18:44:20] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 18:44:20] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 18:44:20] Apply Limit to Message List = 1, Cookie Timeout = 3000
[03/10/09 18:44:20] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 18:44:20] =========================================================================
[03/10/09 18:44:25] =========================================================================
[03/10/09 18:44:25] YPOPs! Version 0.9.7.3
[03/10/09 18:44:25] Configuration:
[03/10/09 18:44:25] Log Mode = Advanced (1)
[03/10/09 18:44:25] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 18:44:25] Max Emails = 400, Leave as unread = 0
[03/10/09 18:44:25] Empty Trash = 1, Empty Bulk = 1
[03/10/09 18:44:25] Download Inbox = 1, Download BulkMail = 1
[03/10/09 18:44:25] Email Category = All
[03/10/09 18:44:25] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 18:44:25] Autostart = 0
[03/10/09 18:44:25] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 18:44:25] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 18:44:25] Apply Limit to Message List = 1, Cookie Timeout = 3000
[03/10/09 18:44:25] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 18:44:25] =========================================================================
[03/10/09 18:44:25] Sending POP3 response to socket 196
[03/10/09 18:44:25] Unknown AUTHORIZATION state command: AUTH
[03/10/09 18:44:25] Sending POP3 response to socket 196
[03/10/09 18:44:25] <> Sending POP3 response to socket 196
[03/10/09 18:44:25] Starting POP3 session for "".
[03/10/09 18:44:25] <> Password received from client.
[03/10/09 18:44:25] <> INBOX added to list of folders to analyze
[03/10/09 18:44:25] <> Bulk Mail added to list of folders to analyze
[03/10/09 18:44:25] <> Login to Yahoo! Mail succeeded
[03/10/09 18:44:25] IMAP Response Dump: 2 OK LOGIN completed
[03/10/09 18:44:26] <> Sending POP3 response to socket 196
[03/10/09 18:44:26] <> Command received from email client: STAT
[03/10/09 18:44:26] STAT Response: +OK 5 75117

[03/10/09 18:44:26] <> Sending POP3 response to socket 196
[03/10/09 18:44:26] <> Command received from email client: UIDL
[03/10/09 18:44:26] UIDL response sent
[03/10/09 18:44:26] Response Dump:
:(null)
[03/10/09 18:44:26] > Sending POP3 response to socket 196
[03/10/09 18:44:26] <> Command received from email client: LIST
[03/10/09 18:44:26] POP3 response for list OK
[03/10/09 18:44:26] POP3 Response Dump: +OK scan listing follows
1 20745
2 20532
3 19756
4 8329
5 5755
.
[03/10/09 18:44:26] <> Sending POP3 response to socket 196
[03/10/09 18:44:27] <> Command received from email client: DELE 1
[03/10/09 18:44:27] DELE response sent
[03/10/09 18:44:27] <> Sending POP3 response to socket 196
[03/10/09 18:44:27] <> Command received from email client: DELE 2
[03/10/09 18:44:27] DELE response sent
[03/10/09 18:44:27] <> Sending POP3 response to socket 196
[03/10/09 18:44:27] <> Command received from email client: DELE 3
[03/10/09 18:44:27] DELE response sent
[03/10/09 18:44:27] <> Sending POP3 response to socket 196
[03/10/09 18:44:27] <> Command received from email client: DELE 4
[03/10/09 18:44:27] DELE response sent
[03/10/09 18:44:27] <> Sending POP3 response to socket 196
[03/10/09 18:44:27] <> Command received from email client: DELE 5
[03/10/09 18:44:27] DELE response sent
[03/10/09 18:44:27] <> Sending POP3 response to socket 196
[03/10/09 18:44:27] <> Command received from email client: QUIT
[03/10/09 18:44:27] IMAP Request Dump: SELECT Inbox
[03/10/09 18:44:27] IMAP Response Dump: * 51 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1] UIDs valid
* OK [UIDNEXT 427014] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft)] Permanent flags
9 OK [READ-WRITE] SELECT completed; now in selected state
[03/10/09 18:44:27] IMAP Request Dump: copy 427010 Trash
[03/10/09 18:44:27] IMAP Response Dump: 10 OK [COPYUID 4 427013 427024] COPY completed
[03/10/09 18:44:27] IMAP Request Dump: store 427010 +FLAGS (\Deleted)
[03/10/09 18:44:27] IMAP Response Dump: 11 OK STORE completed
[03/10/09 18:44:27] Deleting message UID=€™
[03/10/09 18:44:27] IMAP Request Dump: SELECT Inbox
[03/10/09 18:44:27] IMAP Response Dump: * 51 EXISTS
* 0 RECENT
* OK [UIDVALIDITY 1] UIDs valid
* OK [UIDNEXT 427014] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft)] Permanent flags
12 OK [READ-WRITE] SELECT completed; now in selected state
[03/10/09 18:44:27] IMAP Request Dump: copy 427011 Trash
[03/10/09 18:44:27] IMAP Response Dump: 13 OK [COPYUID 4 427013 427025] COPY completed
[03/10/09 18:44:28] IMAP Request Dump: store 427011 +FLAGS (\Deleted)
[03/10/09 18:44:28] IMAP Response Dump: 14 OK STORE completed
[03/10/09 18:51:33] YPOPs! v0.9.7.3 started successfully
[03/10/09 18:51:33] =========================================================================
[03/10/09 18:51:33] YPOPs! Version 0.9.7.3
[03/10/09 18:51:33] Configuration:
[03/10/09 18:51:33] Log Mode = Advanced (1)
[03/10/09 18:51:33] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 18:51:33] Max Emails = 400, Leave as unread = 0
[03/10/09 18:51:33] Empty Trash = 1, Empty Bulk = 1
[03/10/09 18:51:33] Download Inbox = 1, Download BulkMail = 1
[03/10/09 18:51:33] Email Category = All
[03/10/09 18:51:33] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 18:51:33] Autostart = 0
[03/10/09 18:51:33] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 18:51:33] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 18:51:33] Apply Limit to Message List = 1, Cookie Timeout = 3000
[03/10/09 18:51:33] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 18:51:33] =========================================================================
Space Cadet RETIRED,
DeadHead FOREVER
zomby_d_wulf
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 12
Joined: May 10th, 2008, 12:21 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby mwyarm on March 10th, 2009, 7:05 pm

I downloaded 9.7.3 and I am using Outlook Express, XP Home Edition, Service Pack 3 and I still cannot get pass the "authorizing" point. The message indicates the password was rejected. The password is valid because I performed a cut and paste through the WEB screen. I have tried to reset all of the YPOPS Outlook Express configuration using account name as my Yahoo ID without @yahoo.com, POP3, Incoming\Outgoing servers as 127.0.0.1, my server requires authentication with using my incoming mail server id\pswd, and ports 25 and 110 respectively. Ypops sits at the authorizing then times out. I have reverted from Yahoo Asia back to Yahoo US to no avail. Any help would be greatly appreciated.

Now, with the above said, when I log onto the Yahoo via WEB Yahoo appears to have difficulty processing large size files (1mb >) but I don't even see getting past this far since I never get connected.

There was a problem logging onto your mail server. Your Password was rejected. Account: 'ID DELETED HERE', Server: '127.0.0.1', Protocol: POP3, Server Response: '-ERR Bad Login. YPOPs was unable to login to Yahoo! Mail with the given credentials.', Port: 110, Secure(SSL): No, Server Error: 0x800CCC90, Error Number: 0x800CCC92

Thoughts, help?

[03/10/09 21:26:53] YPOPs! Version 0.9.7.3
[03/10/09 21:26:53] Configuration:
[03/10/09 21:26:53] Log Mode = Advanced (1)
[03/10/09 21:26:53] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/10/09 21:26:53] Max Emails = 40, Leave as unread = 0
[03/10/09 21:26:53] Empty Trash = 0, Empty Bulk = 0
[03/10/09 21:26:53] Download Inbox = 1, Download BulkMail = 1
[03/10/09 21:26:53] Email Category = All
[03/10/09 21:26:53] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/10/09 21:26:53] Autostart = 1
[03/10/09 21:26:53] Network IP = ANY, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/10/09 21:26:53] Save Sent Email = 0, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 0
[03/10/09 21:26:53] Apply Limit to Message List = 1, Cookie Timeout = 12000
[03/10/09 21:26:53] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/10/09 21:26:53] =========================================================================
[03/10/09 21:26:53] Sending POP3 response to socket 540
[03/10/09 21:26:53] <xxxxxxx> Sending POP3 response to socket 540
[03/10/09 21:26:53] Starting POP3 session for "Mwyarm1".
[03/10/09 21:26:53] <xxxxxxx> Password received from client.
[03/10/09 21:26:53] <xxxxxxx> INBOX added to list of folders to analyze
[03/10/09 21:26:53] <xxxxxxx> Bulk Mail added to list of folders to analyze
[03/10/09 21:27:24] <xxxxxxx> Login to Yahoo! Mail failed
[03/10/09 21:27:24] IMAP Response Dunp: 2 NO LOGIN failure. Server Error-Please try again after some time. Error code
[03/10/09 21:27:24] <xxxxxxx> Sending POP3 response to socket 540
[03/10/09 21:27:24] <xxxxxxx> closing POP3 socket 540
[03/10/09 21:27:24] <xxxxxxx> Login to Yahoo Mail failed.
[03/10/09 21:30:40] YPOPs! is exiting.
mwyarm
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: March 9th, 2009, 4:46 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby zomby_d_wulf on March 10th, 2009, 7:24 pm

It's still connecting in outlook, starting to d/l then crashing.



I hope this helps, been a while since I broke out visual studio dug into code

'ypops.exe': Loaded 'C:\Program Files\YPOPs\ypops.exe', Binary was not built with debug information.
'ypops.exe': Loaded 'C:\WINDOWS\system32\ntdll.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\kernel32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\ws2_32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\advapi32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\rpcrt4.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\secur32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\msvcrt.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\ws2help.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\user32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\gdi32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\comdlg32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\comctl32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\shell32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\shlwapi.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\winspool.drv', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\oledlg.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\ole32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\oleaut32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\imm32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 7.0\adialhk.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.5512_x-ww_35d4ce83\comctl32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\Documents and Settings\HP_Administrator\Local Settings\TempIadHide5.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\msctf.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\apphelp.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\msctfime.ime', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\mswsock.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\hnetcfg.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\wshtcpip.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\dnsapi.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 7.0\dnsq.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\winrnr.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\wldap32.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\rasadhlp.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\system32\version.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 7.0\miscr3.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 7.0\fssync.dll', No symbols loaded.
'ypops.exe': Loaded 'C:\WINDOWS\WinSxS\x86_Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.3053_x-ww_b80fa8ca\msvcr80.dll', No symbols loaded.
Unhandled exception at 0x00444e86 in ypops.exe: 0xC0000005: Access violation reading location 0x6c65445c.
First-chance exception at 0x00444e86 in ypops.exe: 0xC0000005: Access violation reading location 0x6c65445c.
Space Cadet RETIRED,
DeadHead FOREVER
zomby_d_wulf
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 12
Joined: May 10th, 2008, 12:21 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby anujseth on March 10th, 2009, 8:53 pm

For those wondering why there is a need to use YPOPs! is the Yahoo Asia trick works, read on...

If Yahoo is truly opening up POP3/SMTP access to all users, then there is no need for programs like YPOPs! any longer. But, if this is just experimental, you don't know for sure if this will be around for long.

With YPOPs! what we are trying to do is isolate you from all those changes. As mentioned earlier, IMAP was just the 1st step to support. We will support SOAP as well, which will not require you to switch to Y! Asia at all.

Just like before, the aim is for YPOPs! to try and absorb changes at Yahoo!'s end while keeping its users away from all off it.

It will take some time to stabilize YPOPs! again, but once done, it should make life simpler for all, just like before.
Anuj Seth - YPOPs! Dev & Web Admin
Check out my latest project -- Twitdom - Twitter Applications Database
User avatar
anujseth
Site Admin
Site Admin
 
Posts: 452
Joined: June 24th, 2003, 9:57 am

Re: YPOPs!/Windows 0.9.7.3 Released

Postby kylemcgee on March 10th, 2009, 9:08 pm

Hello Anu -

I installed the 0.9.7.3 release. It installed ok, but Outlook 2007 is still getting the older messages from Yahoo. Here's a log. Hopefully it will help.

Take care!

Kyle

[03/11/09 12:00:47] RETR response sent
[03/11/09 12:00:47] <mcgee_kyle> Sending POP3 response to socket 512
[03/11/09 12:00:48] <mcgee_kyle> Command received from email client: QUIT
[03/11/09 12:00:48] <mcgee_kyle> Sending POP3 response to socket 512
[03/11/09 12:00:48] <mcgee_kyle> closing POP3 socket 512
[03/11/09 12:02:43] =========================================================================
[03/11/09 12:02:43] YPOPs! Version 0.9.7.3
[03/11/09 12:02:43] Configuration:
[03/11/09 12:02:43] Log Mode = Advanced (1)
[03/11/09 12:02:43] Use Proxy = 0, NTLM=0, HTTP Proxy = -:80, HTTPS Proxy = -:80
[03/11/09 12:02:43] Max Emails = 40, Leave as unread = 0
[03/11/09 12:02:43] Empty Trash = 1, Empty Bulk = 1
[03/11/09 12:02:43] Download Inbox = 1, Download BulkMail = 0
[03/11/09 12:02:43] Email Category = All
[03/11/09 12:02:43] Proxy Auth = 0, NTLM=0, Username = -, Password = -
[03/11/09 12:02:43] Autostart = 1
[03/11/09 12:02:43] Network IP = 127.0.0.1, POP3 Port = 110, SMTP Enable = 1, SMTP Port = 25
[03/11/09 12:02:43] Save Sent Email = 1, Enable UIDL = 1, Ignore Exact Size = 1, Hide Tray Icon = 1
[03/11/09 12:02:43] Apply Limit to Message List = 1, Cookie Timeout = 12000
[03/11/09 12:02:43] User Agent = Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
[03/11/09 12:02:43] =========================================================================
[03/11/09 12:02:43] Sending POP3 response to socket 424
[03/11/09 12:02:43] Unknown AUTHORIZATION state command: AUTH
[03/11/09 12:02:43] Sending POP3 response to socket 424
[03/11/09 12:02:43] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:43] Starting POP3 session for "mcgee_kyle".
[03/11/09 12:02:43] <mcgee_kyle> Password received from client.
[03/11/09 12:02:43] <mcgee_kyle> INBOX added to list of folders to analyze
[03/11/09 12:02:44] <mcgee_kyle> Login to Yahoo! Mail succeeded
[03/11/09 12:02:44] IMAP Response Dump: 2 OK LOGIN completed
[03/11/09 12:02:45] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:45] <mcgee_kyle> Command received from email client: STAT
[03/11/09 12:02:45] STAT Response: +OK 2 11267

[03/11/09 12:02:45] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:45] <mcgee_kyle> Command received from email client: UIDL
[03/11/09 12:02:45] UIDL response sent
[03/11/09 12:02:45] Response Dump:
:(null)
[03/11/09 12:02:45] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:45] <mcgee_kyle> Command received from email client: LIST
[03/11/09 12:02:45] POP3 response for list OK
[03/11/09 12:02:45] POP3 Response Dump: +OK scan listing follows
1 5649
2 5618
.
[03/11/09 12:02:45] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:45] <mcgee_kyle> Command received from email client: RETR 2
[03/11/09 12:02:45] IMAP Request Dump: SELECT Inbox
[03/11/09 12:02:45] IMAP Response Dump: * 3 EXISTS
* 0 RECENT
* OK [UNSEEN 2] Message 2 is first unseen
* OK [UIDVALIDITY 1] UIDs valid
* OK [UIDNEXT 59872] Predicted next UID
* FLAGS (\Answered \Flagged \Deleted \Seen \Draft)
* OK [PERMANENTFLAGS (\Answered \Flagged \Deleted \Seen \Draft)] Permanent flags
6 OK [READ-WRITE] SELECT completed; now in selected state
[03/11/09 12:02:46] IMAP Request Dump: fetch 2 BODY[HEADER]
[03/11/09 12:02:46] IMAP Response Dump: * 2 FETCH (BODY[HEADER] {2885}
X-YMAIL-MsgID: 6544_2673971_602_3603_921_0_59870_1963_3100722477
X-YMAIL-UMID: 1_602_AE19v9EAAKkySbc3XgSHdg0oThA
X-Apparently-To: mcgee_kyle@yahoo.com via 209.191.125.77; Tue, 10 Mar 2009 21:00:34 -0700
X-YMailISG: 8o5rkLMWLDuu7C5KVl6AQ4rR_CMKLH5L6eKKbYB8wrErzu9AF7rMKFPDM6Y.YydRFLKSpFv4GUFYB294mH6MXRqv6bl6UrW6mFPq5pxY5bS4Ee7Gk0mJuppaYqbBorIas3ca_BBmJ8qQXjXCHSB26RCSIlQfK1wI_B3FVBAyibPtEBpCtLeAnvHl..EZJGL6uEB9zXRicPaon1mYC_A3XNctDfqDacyj74mQ9EwoUXpk3V_kMX7Wjxj._uSNMrzGS5tXT15GUYALL9EhBHsz_ejvBn2yqa_Nf_zm4Vv5iZH.KfKUhQOuk0h95z01SgmGJFV23jZKA29ptQafyxC9ihC7UzDMcJ9bjvAUt9DwCYwaCXlufJrYxzYV_gE7aa.uK0_HoQbeM_8qi8wW1q43SKCxHnLOqOAAGRMHLCLTZT3Bczpms6MmQ8rgRTubyn2nSY7vETeZj4qXZ0S7WP8kLdWLg6Av3UCbafg1Si1ELM75jd2fKp8OIaXTRaPJmiM-
X-Originating-IP: [209.85.217.178]
Authentication-Results: mta200.mail.re3.yahoo.com from=gmail.com; domainkeys=pass (ok); from=gmail.com; dkim=pass (ok)
Received: from 209.85.217.178 (EHLO mail-gx0-f178.google.com) (209.85.217.178)
by mta200.mail.re3.yahoo.com with SMTP; Tue, 10 Mar 2009 21:00:34 -0700
Received: by mail-gx0-f178.google.com with SMTP id 26so4204174gxk.21
for <mcgee_kyle@yahoo.com>; Tue, 10 Mar 2009 21:00:30 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
d=gmail.com; s=gamma;
h=domainkey-signature:received:received:from:to:subject:date
:message-id:mime-version:content-type:x-mailer:thread-index
:content-language;
bh=bpgKZ07ni/n9MztETlCPHTbD70ZroU1GNPban/8Mmmg=;
b=ZNl/i4H58FbYilfEtnFR26Blo9SzShfaXaE/JE2d4HHfM7EjsV/ZlJIWqaqcdh2zSu
beWSiNB7HKKi3AHLzX/To6dQwp+amx+J4XB+dcST7c4Q32FvmRAJhKlz42NlQHN8QLAn
Ni0bUnurUNJg98hMvUDeqcvKliTHTXorVzPhg=
DomainKey-Signature: a=rsa-sha1; c=nofws;
d=gmail.com; s=gamma;
h=from:to:subject:date:message-id:mime-version:content-type:x-mailer
:thread-index:content-language;
b=b+TyJudYcv6PHj4Hl7KsAFmA7ELZY+eJUHJdmRaHRWNt3JWTwyz73HqwhqYrY2r/vh
yBzTxJkQ3g8Du8YSSNGttdjh4zAtlh7kX18GijigQGXf49Mi38CdddnMgBpQSImGPrSf
xXMbbne0w5PquflBVnhZiJgvPeOOlQVL4UEdg=
Received: by 10.142.154.9 with SMTP id b9mr2871386wfe.126.1236744029797;
Tue, 10 Mar 2009 21:00:29 -0700 (PDT)
Received: from PC446376510999 ([115.134.184.181])
by mx.google.com with ESMTPS id 24sm13231992wff.2.2009.03.10.21.00.27
(version=TLSv1/SSLv3 cipher=RC4-MD5);
Tue, 10 Mar 2009 21:00:29 -0700 (PDT)
From: "Kyle McGee" <mcgeekyle@gmail.com>
To: "'Kyle McGee'" <mcgee_kyle@yahoo.com>
Subject: Test 2 from Gmail
Date: Wed, 11 Mar 2009 12:00:23 +0800
Message-ID: <000601c9a1fd$ea078910$be169b30$@com>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0007_01C9A240.F82AC910"
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: Acmh/ecdYybvXJC4REu3DRwSwunmCA==
Content-Language: en-us

)
* 2 FETCH (FLAGS (\Seen))
7 OK FETCH completed
[03/11/09 12:02:46] IMAP Request Dump: fetch 2 BODY[TEXT]
[03/11/09 12:02:46] IMAP Response Dump: * 2 FETCH (BODY[TEXT] {2046}
This is a multipart message in MIME format.

------=_NextPart_000_0007_01C9A240.F82AC910
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit




------=_NextPart_000_0007_01C9A240.F82AC910
Content-Type: text/html;
charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<html xmlns:v=3D"urn:schemas-microsoft-com:vml" =
xmlns:o=3D"urn:schemas-microsoft-com:office:office" =
xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
xmlns:m=3D"http://schemas.microsoft.com/office/2004/12/omml" =
xmlns=3D"http://www.w3.org/TR/REC-html40">

<head>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Dus-ascii">
<meta name=3DGenerator content=3D"Microsoft Word 12 (filtered medium)">
<style>
<!--
/* Font Definitions */
@font-face
{font-family:"Cambria Math";
panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
{font-family:Calibri;
panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0in;
margin-bottom:.0001pt;
font-size:11.0pt;
font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
{mso-style-priority:99;
color:blue;
text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
{mso-style-priority:99;
color:purple;
text-decoration:underline;}
span.EmailStyle17
{mso-style-type:personal-compose;
font-family:"Calibri","sans-serif";
color:windowtext;}
.MsoChpDefault
{mso-style-type:export-only;}
@page Section1
{size:8.5in 11.0in;
margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
{page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
<o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext=3D"edit">
<o:idmap v:ext=3D"edit" data=3D"1" />
</o:shapelayout></xml><![endif]-->
</head>

<body lang=3DEN-US link=3Dblue vlink=3Dpurple>

<div class=3DSection1>

<p class=3DMsoNormal><o:p>&nbsp;</o:p></p>

</div>

</body>

</html>

------=_NextPart_000_0007_01C9A240.F82AC910--

)
8 OK FETCH completed
[03/11/09 12:02:46] RETR response sent
[03/11/09 12:02:46] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:46] <mcgee_kyle> Command received from email client: QUIT
[03/11/09 12:02:46] <mcgee_kyle> Sending POP3 response to socket 424
[03/11/09 12:02:46] <mcgee_kyle> closing POP3 socket 424
kylemcgee
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 6
Joined: October 23rd, 2008, 4:48 am

Re: YPOPs!/Windows 0.9.7.3 Released

Postby Carex on March 10th, 2009, 11:48 pm

Great. Partial success. For the first time in several weeks I was able to download from Yahoo Asia to Eudora 7.1.0.9 Sponsored Mode, but only once. After getting the files (all four), YPOPs crashed and I was asked to report the problem to Microsoft. I can restart YPOPs, download again, then crash. This at least allows me to get my files.

Follow up. Right after submitting this message I was able to repeatedly download from Yahoo with out a YPOPs crash, but now it's fixated on downloading the same old file that I deleted from the Inbox and the Trash. Don't know where it's getting the file to download?? I have one new file and it's not downloading that one.

Getting closer. Thanks.
Last edited by Carex on March 11th, 2009, 12:07 am, edited 2 times in total.
Carex
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 1
Joined: March 10th, 2009, 11:34 pm

Re: YPOPs!/Windows 0.9.7.3 Released

Postby anujseth on March 11th, 2009, 12:04 am

When does this crash happen? When you try to close YPOPs! or when its downloading the emails?

If its the latter can you PM me the logs (in advanced mode). That might help me narrow down to the region to find the bug.
Anuj Seth - YPOPs! Dev & Web Admin
Check out my latest project -- Twitdom - Twitter Applications Database
User avatar
anujseth
Site Admin
Site Admin
 
Posts: 452
Joined: June 24th, 2003, 9:57 am

Next

Return to Test Forum

Who is online

Users browsing this forum: No registered users and 0 guests

paw prints
cron
SourceForge