YPOPs!/Windows 0.9.6 Alpha 1

Discussion forum for YPOPs!/Windows.


YPOPs!/Windows 0.9.6 Alpha 1

Postby anujseth on April 8th, 2008, 1:44 am

YPOPs!/Windows 0.9.6 Alpha 1 introduces the following changes:

1. Replacement of MIME++ with VMime.
2. Some basic error handling changes.

This is *NOT* a stable release. There are several features which still do not work.

I have tested email downloads using the Classic and New Interfaces of Yahoo! Mail and it seems to be working on a variety of email servers, except for *mc* servers running on the Classic Interface. Configure your Yahoo! interface to either Classic on the New Interface depending on which server it is hosted on. You can always check this by looking at the URL in the address bar when you login using a browser.

Sending emails has not be tested in this release.

Alpha 1 has been made available to receive feedback primarily on the new VMime library that we have incorporated. It will take us a couple of weeks to iron out bugs to make a formal 0.9.6 release.

DOWNLOAD FROM HERE.

Do provide your constructive feedback as part of this thread itself.

Anuj Seth - YPOPs! Dev & Web Admin
Check out my latest project -- Twitdom - Twitter Applications Database
User avatar
anujseth
Site Admin
Site Admin
 
Posts: 452
Joined: June 24th, 2003, 9:57 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby giwo on April 8th, 2008, 8:18 am

Attempted to install the new build on Windows Vista Home Premium (32 bit) and received the following error message:

"This application has failed to start because LIBEAY32.dll was not found. Re-installing the application may fix this problem."

Was there something else we needed to install first?
giwo
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: April 8th, 2008, 8:16 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby anujseth on April 8th, 2008, 10:05 am

@giwo: A mistake from my end. Could you re-download the installer from the same location again?
Anuj Seth - YPOPs! Dev & Web Admin
Check out my latest project -- Twitdom - Twitter Applications Database
User avatar
anujseth
Site Admin
Site Admin
 
Posts: 452
Joined: June 24th, 2003, 9:57 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby Tidder on April 8th, 2008, 10:10 pm

Works great so far running under Wine 0.9.58 on Ubuntu 7.10, using Evolution as my POP client. Had to manually edit ypops.ini, IP addresses would not populate in the dropdown box in the GUI configure. Also, first run under wine, Ypops complained that iconv.dll was missing. Found Here as part of GnuPG.

Have both sent and received with little problem. I did have a minor problem that I hadn't seen with older versions, but never tried this on older versions either. When downloading emails from my "Bulk Mail" folder, Evolution kept giving me an error of "Cannot find message" after showing it was getting ready to download 1 out of 40 emails. But like I said, I hadn't used YPOPs! to access my bulk mail in the past. I emptied it, and haven't had an issue since. I have sent email with no problems at all so far. Have not tried sending with attachments.

Now the burning question, possible to get a hand on the source as to natively compile? I understand it's an alpha release, so if the source isn't available, it's cool with me. I looked in SourceForge CVS, and it seems that the old 0.9.5.3 is still in there.
Tidder
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 11
Joined: April 1st, 2008, 2:41 pm

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby anujseth on April 8th, 2008, 11:34 pm

Tidder wrote:Works great so far running under Wine 0.9.58 on Ubuntu 7.10, using Evolution as my POP client. Had to manually edit ypops.ini, IP addresses would not populate in the dropdown box in the GUI configure. Also, first run under wine, Ypops complained that iconv.dll was missing. Found Here as part of GnuPG.


Thanks for the feedback. I've uploaded a new version with the iconv.dll included as well.

Tidder wrote:Now the burning question, possible to get a hand on the source as to natively compile? I understand it's an alpha release, so if the source isn't available, it's cool with me. I looked in SourceForge CVS, and it seems that the old 0.9.5.3 is still in there.


The complete code will be made available this weekend. I didn't want to check-in till I got some feedback! ;-)
Anuj Seth - YPOPs! Dev & Web Admin
Check out my latest project -- Twitdom - Twitter Applications Database
User avatar
anujseth
Site Admin
Site Admin
 
Posts: 452
Joined: June 24th, 2003, 9:57 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby giwo on April 9th, 2008, 8:37 am

Thanks anuj, that new executable installed and started just fine.

Now on to the next problem. I set up my accounts (I have 2 yahoo accounts) under Windows Live Mail, and started downloading messages using YPOPS. It downloaded the first 40 under account1 with no problem, then moved to account2, where it stopped after the 4th message. YPOPS is stuck with the message "[ACCOUNT NAME] Servicing email application requests" in the task bar, and if I close and re-start the application it gets to the same email and hangs again.

I've attached my log with the names changed to protect the innocent. ;)

Note that the account marked CENSORED is the offender, and is using the NEW Webmail interface, while CENSORED2 seems to be working fine with the old classic interface.

Let me know if there is any more info I can provide for you.

Thanks,

giwo
Attachments
ypops.log
(234.91 KiB) Downloaded 810 times
giwo
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: April 8th, 2008, 8:16 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby Tidder on April 9th, 2008, 11:08 pm

I too am getting the same "Caught Program Exception - aborting POP3 request" in my logs. Evolution is telling me "Cannot get message 5916_2592_715_0_118558_1206_1978205531: Unknown reason". This was the error I was getting before when I had stated I dumped my Bulk mail and it went away. Only thing that has changed is the message ID. What's odd is it marks some of my mail in my Yahoo inbox as read. It appears the email that is causing the problem this time is a new message alert from MySpace. Deleted that message, then YPOPs! started working fine again. Can attach my log if needed.
Tidder
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 11
Joined: April 1st, 2008, 2:41 pm

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby pranav on April 11th, 2008, 6:20 am

Hey Anuj....the software is just too kool and convenient..I am using the 0.5.9.1 version...there are just 2 major problems I am facing here..first the failed mails are received after 2 -3 days...that is my biggest concern...you can imaging the inconvenience caused by that.. the second concern is that if I receive a mail in outlook the same mail is not seen in the yahoo mail... Are there any settings for that???Please reply at the ealiest..I am working and not been able to use these features would be a big problem...Thank you...
pranav
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 2
Joined: April 11th, 2008, 6:14 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby john3 on April 12th, 2008, 1:06 am

I'm working with Vista and Thunderbird and this version is doin' a great job.
john3
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 3
Joined: July 18th, 2007, 12:17 am

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby mtharan on April 13th, 2008, 8:49 am

Dear Chi.Anuj!

I have attached the advanced Log file using YPOPs! I am using Vista Ultimate as OS and installed the Alpha1 version of YPOPs! But I am unable to retrive the mails using the pop3 protocol. Kindly let me know how to configure it on Windows Live Mail and incredimail, both the update version as of date.

The aplomb of YPOPs! forum is your real pep and I am sure you succeed in all your endeavour with less efforts!

with best wishes

Muralitharan. A.S.
Attachments
ypops.log
(195.08 KiB) Downloaded 862 times
mtharan
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 10
Joined: March 19th, 2008, 8:02 pm

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby mtharan on April 13th, 2008, 10:31 am

Dear Chi. Anju,
Following is the message when retriving the message using pop3 protocol.

Yahoo API reported the following error:
Expired credentials.

with best wishes,
Muralitharan. A.S.
mtharan
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 10
Joined: March 19th, 2008, 8:02 pm

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby Tidder on April 13th, 2008, 2:04 pm

Just an update with the problem I was having on the Alpha release. I've upgraded both of my yahoo mail accounts to the new mail interface, I was still using classic on both. So far, no more errors using Evolution. Able to download all the mail from both my inbox and Bulk mail. Able to send without a hitch. Will keep testing though. Thanks! :)

Tidder
Tidder
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 11
Joined: April 1st, 2008, 2:41 pm

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby KarinaG2 on April 13th, 2008, 2:52 pm

Was working ok all morning with Thunderbird, but suddenly froze while downloading messages, had to reboot my laptop.
Using new Yahoo mail.

Karina
KarinaG2
YPOPs! Newbie
YPOPs! Newbie
 
Posts: 1
Joined: April 13th, 2008, 2:47 pm

YPOPs!/Windows 0.9.6 Alpha 1

Postby mtharan on April 13th, 2008, 8:01 pm

Dear Chi.Anuj,

Now I am able to retrive messages. But it duplicates and more slow in getting the messges out from the server to my machine. this happened to be after I changed to the new verison of yahoo from classic. My server address in the yahoo website is "http://us.mg2.mail.yahoo.com/dc/launch" If this is of help to you in improving (y)our software project YPOPs!, just use it.

with best wishes,
Muralitharan
mtharan
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 10
Joined: March 19th, 2008, 8:02 pm

Re: YPOPs!/Windows 0.9.6 Alpha 1

Postby mtharan on April 13th, 2008, 10:48 pm

Dear Mr.Anuj,

It is quite amazing. Now that I got despatched two mails using the SMTP with the old setting using Windows Live Mail on Vista Platform. I do not know how that is sent out. This is for your information. Also find attached the recent log generated on my machin in the YPOP folder in Progam files.

with best wishes,
Muralitharan. A.S.
Attachments
ypops.log
(195.16 KiB) Downloaded 922 times
mtharan
YPOPs! Rookie
YPOPs! Rookie
 
Posts: 10
Joined: March 19th, 2008, 8:02 pm

Next

Return to YPOPs!/Windows

Who is online

Users browsing this forum: No registered users and 1 guest

paw prints
cron
SourceForge